WordPress有木有现成好用像自带的自动摘要那样,自动为文章添加相关标签的插件呢?WordPress的文章标签功能可以很好的对文章进行分类、归纳,与直接给文章一个大的分类目录不同,标签没有层级关系,标签的设计更多的是为了将主题明确相似的文章组织在一起。为了给搜索引擎访客提供更具相关性的文章推荐,每次写完文章都是冥思苦想的手动给文章添加标签(Tags),很多时候觉得比较麻烦很繁琐很没效率不是嘛?甚至有时写完文章会忘记为文章添加标签!WordPress-Code-Image

搜索尝试了好些自动标签插件都不尽如意,于是WP AutoTags这款WordPress文章标签自动化的辅助插件,为解决以上烦恼被简单制造了出来,它为在WordPress发布文章以及更新编辑文章时经常爱忘设置标签的人们工作,根据文章标题或文章正文内容通过调用了一个简易分词接口对文章进行分析,提取出文章中明确重点的关键词(Keywords)添加为文章的标签。文章关键词基于TF-IDF算法提取,标签与文章具有高相关性,目前工作状态良好,使用插件以后极大的提高文章通过标签管理的便利,通过主题明确的标签将所有相关文章联系起来,一定程度上能帮助搜索引擎快速识别文章主旨要义,同时也再不用纠结文章添加什么标签好而发愁,当然如果你乐意自己动手为文章添加标签它也是不会出来捣鬼做乱的:)

WP AutoTags插件的工作方式以及主要功能简介

  • 自动从文章标题或者文章内容的组合中提取高权值关键字/词为文章添加相关标签。
  • 文章提取关键字/词的API基于TF-IDF算法实现,相关性强,目前仅支持中文(简/繁)&英文文本。
  • 插件内置的TF-IDF文本关键词提取接口失效时将会依赖WordPress自身现有已知的标签库进行匹配、添加工作。
  • 插件只在文章发布更新或者修改编辑且文章没有设置标签时(没标签时WordPress的自动保存文章草稿机制也会触发本插件一次)工作。
  • WP AutoTags可以设置自动添加标签的数量,卸载绿色无任何残留设置(已设置标签的文章不会丢失标签)。

安装使用WordPress自动标签(WP AutoTags)插件

一、WordPress后台管理界面—>插件—>安装插件,在搜索框中输入【WP AutoTags】查看安装启用即可。

二、如果你所使用的虚拟主机存在某些限制不支持WordPress后台直接在线安装插件,那么你可以点击【下载WP AutoTags】立即下载插件最新版本。下载完成后解压上传至wp-content/plugins/目录下,前往后台启用WP AutoTags插件即完成安装使用。

后台通过 设置->撰写 页面对插件进行配置。一般维持插件默认设置就可获得良好的体验。

===WP AutoTags插件常见问题回答===
Q:这货调用接口工作会不会收钱啊,看到很多插件作者随便写个插件各种收钱额。
A:收个屁的钱,作者到现在连赞助的页面都没有出来一个,如此任性,这破插件还会收钱?

Q:为什么自动保存文章草稿也会触发插件自动添加标签?
A:这是插件一个良性BUG,在文章没有设置标签时保存为草稿,插件也会自动的根据插件设置为草稿进行标签添加。

Q:插件调用的文章自动关键词标签的接口会不会保留数据?
A:接口服务端没有进行任何数据滞留的操作,接口仅对文章进行实时的分词并提取关键字的处理。但作者无法保证用户调用接口整个过程不存在数据泄露,对于安全性有较高要求的用户可以自行修改插件代码使用HTTPS协议与文章关键词提取接口进行通讯。

Q:WP AutoTags可以自己修改使用吗?
A:插件非常简单代码开源,允许任何人对插件进行任意修改但只能在非商业且情景下使用。

WP AutoTags使用注意事项:

插件在PHP5.4+下测试通过,PHP版本低于5.4的朋友使用本插件时因为某些特性可能无法正常工作。如果插件在使用过程中出现问题或者对于本插件你有更妙的想法或建议请在下方留言与作者取得联系。

comment-author avatars

Zhys

Cherish the time! Don't waste even nine seconds to remember the past, live in the present and for the future planning.

猜你喜欢...

5 回复

  1. comment-author avatars 孤军奋战说道:

    很不错,省时省力的。

  2. comment-author avatars 逍遥乐说道:

    无法启用,因为它引起了一个致命错误(fatal error)。
    Parse error: syntax error, unexpected wp-autotags\wp-autotags.php on line 74

    无法启动

    • comment-author avatars Zhys说道:

      请注意插件注明的PHP版本要求,PHP5.4及以上版本支持函数式语法,也就不会报错啦。改写(一行变多行)插件中的函数式语法可以变成PHP通用的版本,代码量得多个几行,不过PHP5.4以下版本实在效率低低。

  3. comment-author avatars GF发现说道:

    这个不错~打包带走 :grin:

  4. comment-author avatars 网扑蜘说道:

    很好的懒人工具,谢谢 :wink: :wink: :wink:

发表评论

电子邮件地址不会被公开。 必填项已用*标注

邮件通知